summaryrefslogtreecommitdiff
path: root/include/console.h
Commit message (Collapse)AuthorAgeLines
* stdio/device: rework function naming conventionJean-Christophe PLAGNIOL-VILLARD2009-07-18-36/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | So far the console API uses the following naming convention: ======Extract====== typedef struct device_t; int device_register (device_t * dev); int devices_init (void); int device_deregister(char *devname); struct list_head* device_get_list(void); device_t* device_get_by_name(char* name); device_t* device_clone(device_t *dev); ======= which is too generic and confusing. Instead of using device_XX and device_t we change this into stdio_XX and stdio_dev This will also allow to add later a generic device mechanism in order to have support for multiple devices and driver instances. Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com> Edited commit message. Signed-off-by: Wolfgang Denk <wd@denx.de>
* console.h: remove unused prototype 'console_realloc'Jean-Christophe PLAGNIOL-VILLARD2009-05-15-2/+0
| | | | Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* Initial revisionwdenk2000-11-12-0/+38